博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
POJ1651 区间dp
阅读量:1905 次
发布时间:2019-04-26

本文共 1934 字,大约阅读时间需要 6 分钟。

Multiplication Puzzle
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9879   Accepted: 6107

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 
The goal is to take cards in such order as to minimize the total number of scored points. 
For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000
If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

610 1 50 50 20 5

Sample Output

3650

题意:给你一个序列,然后让你对他进行移动,顺序任意,每次移动代价是该位置上的数*其左边的第一个数*其右边第一个数,第一个数和最后一个数不能移,让你求出将中间数全部移除之后的最小代价。

思路:一个区间dp,dp[i][j]表示从i到j的最优解,可以考虑从i到k,k+1到j的最小代价,然后可以推出状态转移方程如下;

dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+a[i-1]*a[k]*a[j]);

代码

#include<bits/stdc++.h>

using namespace std;

const int maxn=105;
const int INF=0x4fffffff;//无穷大
int a[maxn];
int dp[maxn][maxn];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int l=2;l<n;l++)//第一个和最后一个不能移,枚举区间长度
        {
            for(int i=0;i<=n-l+1;i++)//生成左右区间
            {
                int j=i+l-1;
                dp[i][j]=INF;
                for(int k=i;k<j;k++)//枚举中点
                {
                    dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+a[i-1]*a[k]*a[j]);
                }
            }
        }
        printf("%d\n",dp[2][n]);
    }
    return 0;
}

转载地址:http://tjncf.baihongyu.com/

你可能感兴趣的文章
Linux下防火墙开启相关端口及查看已开启端口
查看>>
一次zabbix连接不上mysql数据库的经历
查看>>
Zabbix error - Invalid first parameter.
查看>>
通过maven打包依赖jar,打包主类,在pom.xml中设置
查看>>
redis中pipeline的使用
查看>>
linux命令seq产生序列
查看>>
jedis操作redis报错DENIED Redis is running in protected mode
查看>>
apache配置https
查看>>
ORACLE查出表所有的触发器及触发器详细信息
查看>>
ubuntu apt-get 错误 Temporary failure resolving 'us.archive.ubuntu.com'
查看>>
oracle RAC环境启动报ORA-01031: insufficient privileges
查看>>
redis主从复制配置
查看>>
Redis重启数据丢失问题
查看>>
在线录像就这么简单
查看>>
Win7系统提示对于目标文件系统文件过大
查看>>
redis使用--pattern选项遍历查询
查看>>
openssl: error while loading shared libraries: libssl.so.1.1
查看>>
详细记录一次Tomcat服务器和Nginx服务器的缺省banner的修改全过程
查看>>
Linux下不同后缀的压缩包的解压命令
查看>>
linux命令tee
查看>>